Browse Source

Update intersection-observer to version 0.4.0 (#4398)

tags/v1.5.0rc2
Yamagishi Kazutoshi 2 years ago
parent
commit
f2233c3e25
3 changed files with 6 additions and 11 deletions
  1. 2
    7
      app/javascript/mastodon/components/status.js
  2. 1
    1
      package.json
  3. 3
    3
      yarn.lock

+ 2
- 7
app/javascript/mastodon/components/status.js View File

@@ -107,17 +107,12 @@ export default class Status extends ImmutablePureComponent {
this.height = getRectFromEntry(entry).height;
}

// Edge 15 doesn't support isIntersecting, but we can infer it
// https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/12156111/
// https://github.com/WICG/IntersectionObserver/issues/211
const isIntersecting = (typeof entry.isIntersecting === 'boolean') ?
entry.isIntersecting : entry.intersectionRect.height > 0;
this.setState((prevState) => {
if (prevState.isIntersecting && !isIntersecting) {
if (prevState.isIntersecting && !entry.isIntersecting) {
scheduleIdleTask(this.hideIfNotIntersecting);
}
return {
isIntersecting: isIntersecting,
isIntersecting: entry.isIntersecting,
isHidden: false,
};
});

+ 1
- 1
package.json View File

@@ -57,7 +57,7 @@
"glob": "^7.1.1",
"http-link-header": "^0.8.0",
"immutable": "^3.8.1",
"intersection-observer": "^0.3.2",
"intersection-observer": "^0.4.0",
"intl": "^1.2.5",
"intl-relativeformat": "^2.0.0",
"is-nan": "^1.2.1",

+ 3
- 3
yarn.lock View File

@@ -3608,9 +3608,9 @@ interpret@^1.0.0:
version "1.0.3"
resolved "https://registry.yarnpkg.com/interpret/-/interpret-1.0.3.tgz#cbc35c62eeee73f19ab7b10a801511401afc0f90"

intersection-observer@^0.3.2:
version "0.3.2"
resolved "https://registry.yarnpkg.com/intersection-observer/-/intersection-observer-0.3.2.tgz#9ed30021c08b29e9e8565c8d512ed84515727433"
intersection-observer@^0.4.0:
version "0.4.0"
resolved "https://registry.yarnpkg.com/intersection-observer/-/intersection-observer-0.4.0.tgz#e7c3580be96fc1698170250b500da986c59824fb"

intl-format-cache@^2.0.5:
version "2.0.5"

Loading…
Cancel
Save