pict-rs-integration-tests/pict-rs-integration-tests.nix
2023-07-20 20:27:45 -05:00

22 lines
480 B
Nix

{ lib
, nixosTests
, rustPlatform
}:
rustPlatform.buildRustPackage {
pname = "pict-rs-integration-tests";
version = "0.1.0";
src = ./.;
cargoLock.lockFile = ./Cargo.lock;
nativeBuildInputs = [ ];
passthru.tests = { inherit (nixosTests) pict-rs-integration-tests; };
meta = with lib; {
description = "A simple image hosting service";
homepage = "https://git.asonix.dog/asonix/pict-rs-integration-tests";
license = with licenses; [ agpl3Plus ];
};
}