pict-rs-proxy/pict-rs-proxy.nix
asonix 399b565b0e
All checks were successful
continuous-integration/drone/push Build is passing
Update dependencies
2023-05-25 13:41:40 -05:00

28 lines
563 B
Nix

{ lib
, makeWrapper
, nixosTests
, protobuf
, rustPlatform
, stdenv
}:
rustPlatform.buildRustPackage {
pname = "pict-rs-proxy";
version = "0.4.0-rc.2";
src = ./.;
cargoLock.lockFile = ./Cargo.lock;
PROTOC = "${protobuf}/bin/protoc";
PROTOC_INCLUDE = "${protobuf}/include";
nativeBuildInputs = [ ];
passthru.tests = { inherit (nixosTests) pict-rs-proxy; };
meta = with lib; {
description = "A simple image hosting service";
homepage = "https://git.asonix.dog/asonix/pict-rs-proxy";
license = with licenses; [ agpl3Plus ];
};
}