relay/relay.nix
asonix 5c0c0591dd
All checks were successful
/ clippy (push) Successful in 1m24s
/ tests (push) Successful in 2m2s
/ check (armv7-unknown-linux-musleabihf) (push) Successful in 2m33s
/ check (x86_64-unknown-linux-musl) (push) Successful in 2m26s
/ check (aarch64-unknown-linux-musl) (push) Successful in 2m38s
Prepare 0.3.112
2024-04-14 22:47:38 -05:00

24 lines
451 B
Nix

{ lib
, nixosTests
, rustPlatform
}:
rustPlatform.buildRustPackage {
pname = "relay";
version = "0.3.112";
src = ./.;
cargoLock.lockFile = ./Cargo.lock;
RUSTFLAGS = "--cfg tokio_unstable";
nativeBuildInputs = [ ];
passthru.tests = { inherit (nixosTests) relay; };
meta = with lib; {
description = "An ActivityPub relay";
homepage = "https://git.asonix.dog/asonix/relay";
license = with licenses; [ agpl3Plus ];
};
}