relay/relay.nix
asonix 8c14d613f7
Some checks failed
/ clippy (push) Failing after 1m25s
/ tests (push) Successful in 1m41s
/ check (aarch64-unknown-linux-musl) (push) Successful in 2m11s
/ check (armv7-unknown-linux-musleabihf) (push) Successful in 2m9s
/ check (x86_64-unknown-linux-musl) (push) Successful in 2m5s
Prepare v0.3.114
2024-06-23 13:45:10 -05:00

23 lines
451 B
Nix

{ lib
, nixosTests
, rustPlatform
}:
rustPlatform.buildRustPackage {
pname = "relay";
version = "0.3.114";
src = ./.;
cargoLock.lockFile = ./Cargo.lock;
RUSTFLAGS = "--cfg tokio_unstable";
nativeBuildInputs = [ ];
passthru.tests = { inherit (nixosTests) relay; };
meta = with lib; {
description = "An ActivityPub relay";
homepage = "https://git.asonix.dog/asonix/relay";
license = with licenses; [ agpl3Plus ];
};
}